Amcodec Hardware Acceleration


#21

This actually makes it much worse. I tried every combo of refresh rate and 60 performs the best but not great. I have the vero connected to the hdmi in of an oppo 203. I tried changing the video output resolution settings by forcing 24hz as well and it didn’t help. I’ve tested without the oppo and no change so I’m convinced this is a vero issue.


#22

If you didn’t use passthrough, Sync Playback to Display would probably do the trick


#23

But I do use passthrough. Everything flows through a denon x6200w. This is starting to sound like there is no fix. Turning off hardware acceleration made things better but created other issues like a crazy high cpu and inability to play movies properly. Is there a way to leave the hardware acceleration off but have it automatically switch on if I try to play a movie?


#24

Not trivially, but if the trailers are below HD then you could change accel to HD and up.

Sam


#25

Most of them are 1080p actually. Nothing else I can try?


#26

No – I’ll look in to this further, but it’s low on the list of priorities.
This is effectively PiP which isn’t planned until far later in Kodi’s development cycle.


#27

Hi gkron

I have a button setup to display a trailer in the skin using the mq7 skin also. Plays all quality fine although I’m using a rpi3.

I’m not using tvtunes for this just using skinning displaying a videowindow in the GUI.

For a quick test can you install the confluence skin. Play a video file then navigate back to the main screen. I think confluence by default displays the video in background of main screen. If doesn’t check in settings for show video in background or something.

See if it stutters there.