Amcodec Hardware Acceleration


#1

On the Vero 4k I use the TvTunes addon to display trailers when browsing through my movie library. With this option on the trailer playback is choppy. If I turn it off it’s fine. However with it off my cpu is at 300% when browing my movie library with trailers playing. It stays high when playing a movie as well. With acceleration on it goes all the way down to 35% or so when playing a movie. Is there a possible solution to this? Can I set acceleration to be off when browsing but on when I play a movie? Or is there another option to use another video player?


#2

Sounds odd. Debug logs and a sample may give some clues

Sam


#3

Can you use the below log? This one was with it on. I can send another one later with it off as well.

https://paste.osmc.tv/irewopariv


#4

Do you have a sample of the file?


#5

One of the trailers? If so yes. How do I upload it?


#6

Just use dropbox or something like that and give sam the url


#7

here you go…


#8

Also here is a sample pic of where the trailer would automatically play and has the issue when browsing movies.


#9

Are you saying you can play the trailer fine, just not while browsing?
If the trailers are low quality, disable acceleration for < HD, i.e. HD and up


#10

No the trailers play but it looks like the frames per second are off when it does. Hard to explain but it’s not smooth. It basically micro stutters with the acceleration on. It’s for all trailers regardless of quality when they play while browsing movies. Basically I browse and when I stop on a movie the trailer automatically starts. I messed with all those quality settings and the only thing that works is turning it off. If I do that the CPU is crazy high though.


#11

Post a debug log playing it full screen with Adjust Refresh Rate enabled

Sam


#12

https://paste.osmc.tv/omisohuyuh

I played two different trailers. The same one I attached a few posts ago and a 1080p one. Same result. Both microstutter. I played the trailer from the context menu with tvtunes plugin disabled


#13

Hi Sam. Did you have a chance to review the log?


#14

Can someone do me a favor and try to play a trailer from within Kodi? Does it play without microstutter with the Amcodec on? They stutter horribly for me. It doesn’t matter what quality the trailer is whether it’s 1080p or 720p etc. I have no issues playing them from a windows machine. If I turn off the amcodec they play with less stutter but then I have to put it on to play movies properly.


#15

Sorry for the late reply. I’ve looked at this and can’t produce the stuttering. However I am watching the videos with Adjust Refresh Rate enabled; and I am not browsing the GUI when doing this.

Can you confirm if you still have problems when doing the same?

Sam


#16

I’ve tested while browsing the GUI in the movies section and also after hitting the info button while on a movie. That brings up the context menu which allows me to play the trailer from there. It opens a separate window for it. Same thing that way too as it stutters. Adjust refresh rate is set to always. How else can I play the trailer if I’m not inside Kodi?


#17

Hi Sam. Can you tell me your result of playing a trailer inside kodi whether while browsing the gui or through the context menu?


#18

If I play the video through the GUI, there are stutters. But this is because the GUI is running at a different frame rate to the video.


#19

Is there a way to get it to work properly? Can I force the gui to be a different frame rate? What fram rate is the gui? My 2 windows machines have no issues…


#20

You could try changing the GUI to 24Hz which is quite close; but the GUI may look less smooth