444 10bit output from vero 4k


#104

You can just clear it, as in echo nothing
Or reboot. It’s not persistent unless in rc.local.


#105

i read thorugh the HDR related threads and im still a bit confused :slight_smile:

I have a late 2015 LG OLED (55EF9509), HDR Mode activates fine.
Is it confirmed on all systems that the vero defaults to 8 bit?

I tried the 444,10bit force but this resulted in playback issues with HDR stuff (display keeps switching black and HDR OFF ON)
Then i researched a bit more and found this:

So it seems my TV wont support 444 10 bit but only 422 10 or 12 bit? And i should paste this into /sys/class/amhdmitx/amhdmitx0/attr instead?

I tried “422,12bit” right now and this seems to work (atleast compared to 444) but dont have the time right now to really compare it against the default output.

OK did a bit more testing but no logs at this time:

422, 12bit : Works fine in 2160p60, but everything else (1080p) gives a green tint
420, 12bit: Works fine in 2160p60, but everything else (1080p) gives a green tint
420, 10bit: display turns off and on all the time, regardless of what resolution is set

I will try to do a bit more indepth testing tomorrow with proper logs.
And btw ultra deep color was of course enabled for the hdmi port of the vero.


#106

When i´m copy and paste echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr to the shell then it returns 444, 10bit but when i´m copy and paste this with nano in the rc.local and do a reboot of the Vero i can see an error message that something is wrong with the rc.local…

rc

I don´t find the mistake… :frowning:


#107

What does the error say?
You can remove sudo, as rc.local already runs as root.


#108

After you log into putty what exactly do you type to get to the rc.local file? I’ve tried a few times and can’t seem to find it. If I type cd /etc and then dir it’s not listed. Can you layout exactly what I need to type if I login as osmc with password osmc? Thanks!


#109

This is a screen of the rc.local:

rc

And this is the message @the vero reboot:


#110

From the command line please run hd -c /etc/rc.local | paste-log and post the URL it returns.


#111

-bash: hd: command not found
https://paste.osmc.tv/kunurevugo


#112

It looks like hd isn’t installed.

sudo apt-get update
sudo apt-get install bsdmainutils

and re-run the hd command.


#113

https://paste.osmc.tv/uqacisador


#114

As I suspected, your rc.local file contains CR-LF line endings, which is the MSDOS format (it should be LF for *nix systems).

You can install dos2unix and fix the file:

sudo apt-get install dos2unix
cd /etc
sudo cp rc.local rc.local.dos
sudo dos2unix rc.local

Out of interest, how did you manage to do this?

Edit Fixed missing sudo


#115

Copy the line from the browser of my windows pc and paste it in the nano editor via shell… that was the mistake…
Thanks for help, seems that it works, no errormessage @ boot!


#116

I did all that, and it worked - but only for a few seconds, after which both picture and sound disappeared, and Vero 4K became completely unresponsive. Vertex reported there was no incoming signal. Had to yank the power and re-plug it to breathe life into Vero 4K again.


#117

Looks like the green tint with 12bit has been solved on the kodi forum, something for you to implement @sam_nazarko?


#118

Indeed, I notice that. I believe the issue is solved in a newer, upstream version of the kernel.

However the changes made in this kernel are currently unsuitable as it would break HDR.

We may be able to cherry-pick these changes. We will definitely get them later with the next kernel sync.

Sam


#119

Good to know, I worked around the issue by buying a HD Fury Linker but if the Vero 4k can support proper 12 bit video at some point I’ll be able to just sell that on :slight_smile:


#120

It absolutely will. It’s just a matter of when (whether it’s a month or two months); not if.


#121

Hi Sam,

can you confirm the correct way to do HDR now then please.

Is it still ‘echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr’ or the same in rc.local.

Or is there something better/new?

Thanks

-Mat


#122

You still want to set that for now, yes.


#123

Thanks