444 10bit output from vero 4k


#64

Something like: echo “422,12bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

Can’t test this here currently.


#65

how to revert back? everything turned green for osmc


#66

Do you have a TV or a projector?
With a projector (if you have no Sony 760) you need a HDFury Linker to display the correct colors BT2020 and 10 bit.


#67

Just reboot to reset.

$ sudo reboot

#68

I haven’t done any extensive testing or logging but I can’t seem to get 12bit working at all.

Trying to get 420 12bit working as that’s the best my pj will support. Screen just goes green. Both on the pj and the oled. What I’ve read in the forum suggests this seems to be the case for everyone.

Same results with librelec btw so suggests a problem with support in the amlogic kernel maybe?

420 12bit works fine on the Nvidia Shield btw.

I can get HDR BT2020 with 8bit video, that’s what the Vero 4k shield seems to default to via my pj.

EDIT: I still need to do some proper testing, hooking up the pj directly and not via the receiver etc.


#69

I have a projector and a video processor, LUT box for tone mapping (Lumagen Pro).


#70

bit confused by this… i typed the cmd and did ‘sudo reboot’ to get back to Kodi, does this reset the setting?! or is there a different way to get back to Kodi after typing the cmd?!

my current setup is Vero 4K > Denon AVR-6200W > LG 65C7P …and i keep getting HDR BT.2020 8 bit output.

Power strip where all my equipment is hooked up, is shut off when not being used, so does a power cycle of the unit, reset this setting?!


#71

I assume that you are not connecting to the 4K via SSH but with a connected keyboard. If that’s the case after changing the setting do

sudo systemctl start mediacenter

to restart Kodi. sudo reboot will reboot you system, and the setting will be reset to default.


#72

Thanks bmillham. Yes, was doing it via keyboard.

So does powering the unit off/on also reset the setting? If so, anyway to have it stick permanently.


#73

https://osmc.tv/wiki/general/running-scripts-on-startup-and-shutdown/


#74

I hope you are not just turning the power off! That could/will eventually lead to filesystem corruption. Always power off using the menu option first! Or just leave it on as it’s meant to be always on.


#75

I have a similar setup and i was getting HDR 8 bit BT2020. After i changed the output manually to be at 10 bit i get 10 bit HDR BT2020. There is something wrong with the way the vero 4k and/or kodi handles those signals. My current setup works with all other equipment i have and it correctly outputs HDR 10 bit BT2020 with the appropriate source. I dont think there is anything wrong with your equipment chain.


#76

You are correct, i shutdown the unit via the GUI (wait for red light) along with all my other a/v equipment and then i turn off my power line conditioner.

Yiorgos - i was able to get 10bit output to work, with the cmd change + restarting Kodi (via cmd line), but soon as i restart the device it all reverts back to 8bit… as other users stated, it’d be nice to have this incorporate and working on the next update!!


#77

So, is there anything that can be done to fix/confirm this. or should I just give up as 8bit is the only option for me?


#78

You sure your hdmi cable is certified for 18Gbit?
Tried it with other devices that can do same or higher output?

Most if not all problems I hear relate to incompatible cables or avr’s.


#79

The format I’m asking for doesn’t require 18 GHz cable, it is 4K@25 4:2:2 but I have changed the HDMI cable between the vero 4K and the video processor with HDMI @18 Ghz but same result.


#80

For me 422,12bit works for 50+ only, but everything lower gives a yellow/greenish look and display info returns 444 8bit at that time.


#81

Do you see a difference when veiwimg 8bit vs 12bit?


#82

I do so a differnce in the menu, haven’t checked a 50+ Hz 4k movie yet though.


#83

Here is another test,

  • Connected Vero 4K directly to the projector, using 18 Ghz cable,
  • Execute the command “echo ‘422,12bit’ > /sys/class/amhdmitx/amhdmitx0/attr”

Result: Kodi Green Screen