444 10bit output from vero 4k


#43

Is there any way I can see on the commandline what the current display mode is?

I only see VIC:93 in /sys/class/amhdmitx/amhdmitx0/disp_mode when playing a HDR file and VIC:352 when in the menu.
But no idea what it stands for :slight_smile:


#44

hi, i´m new here and just got my Vero4K.
Thanks for a fast delivery, the unit is looking good.

After a couple of hours of a very frustrating fstab setup i have now managed to get some files running.

I have the same issue as pulham in this thread, no 10bit.

I’m hoping this is fixable.
Since i’m coming from a Shield I am fed up with wrong colorspaces etc.

If it is the EDID that is at fault, is it possible to fool it?

My EDID:
Rx Brand Name: DON
Rx Product Name: DENON-AVR
Manufacture Week: 0
Manufacture Year: 2015
Physcial size(cm): 165 x 93
EDID Verison: 1.3
EDID block number: 0x1
blk0 chksum: 0x3a
Source Physical Address[a.b.c.d]: 4.5.0.0
native Mode f0, VIC (native 255):
ColorDeepSupport b8
97 16 31 4 19 5 20 32 33 34 93 94 95 96 101 102 98 99 100 7 22 3 18 15 36 30 38 95 94 93 98 353 352 357 358
Audio {format, channel, freq, cce}
{1, 7, 7f, 7}
{2, 5, 7, 0}
{7, 5, 1e, 0}
{10, 7, 6, 1}
{11, 7, 7e, 3}
{12, 7, 7e, 1}
{11, 7, 7e, 1}
Speaker Allocation: 5f
Vendor: 0xc03
MaxTMDSClock1 300 MHz
Vendor2: 0xd85dc4
MaxTMDSClock2 600 MHz
ColorMetry: 0xc3
SCDC: 1
RR_Cap: 0
LTE_340M_Scramble: 0
HDR DeepColor
checkvalue: 0x3a340000


#45

Did you try the rc.local suggestion to make sure you can get things to look ok manually?

Sam


#46

I have now tried the rc.local -> echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr thing.

Made my 10bit 24p HDR videob black out, I guess HDMI limitation?


#47

For me the 444,10bit worked, but it put the kodi menu in 10bit as well… that put the colors way off it seems.


#48

Can you upload a full set of logs so we can see what can be done?

Sam


#49

Tried it again today, 444,10bit command did work this time.
Got 10 bit output on HDR as well.

Going to try and get the log published.

Still having problems with mounting shares I see, need to have another look at fstab.
Manually it is fine, different topic though.

[EDIT]
Download link removed.


#50

Please use a pastebin type site to provide logs. Nobody wants to download your text file and then have to chase it down to delete it or risk your file actually being something less than innocent.

http://paste.osmc.io

Thanks


#51

Sure.
It didnt let me when I tried so that’s why I saved it in a .txt file.

Sorry for the inconvenience.

It seems to work now: http://paste.osmc.io/tenifitase.coffee


#52

It seems that 420,10bit isn’t working… I get a blue screen from the receiver, should this work?

[edit] aahh 420 is only for 50/60Hz, just tested … it worked! [/edit]


#54

I’ve tried some 8 bit material with 444,10bit activated and it looks normal for me.
Going to keep that setting and hopefully it will keep looking good.

Great forum and great software/hardware. So far it has been blowing the Shield out of the water!


#55

Have you watched 4K SDR content that looks ok?
My gui settings are 4k 50Hz and the colors look incorrect, haven’t tried other content yet though.

This needs to be automated offcourse, switching to 8, 10 or 12 bits and with the correct chroma subsampling.
For now I log in with SSH and set 10bit with HDR viewing and clear it when I’m finished, not very wife friendly, but it works for now :slight_smile:

@sam_nazarko if you need any logs or testing to be done, let me know.


#56

Just watched some 720p and 1080p SDR content but that is totaly over saturated when I have 444,10bit set, clearing it makes the colors normal again.


#57

Im using 1080p 60hz in menu.

I dont have any 4k SDR files I think, but 720p/1080p SDR looks OK to me at least.
It is not using HDR colorspace like the shield did, that’s when I experienced over saturated colors etc.


#58

What about the automated switching which should come via update together wirh GUI buttons for this topic?


#59

It’s being worked on

Sam


#60

perfect… look forward for a first test…


#61

Good day Sam, has this been done? I am trying to program my vero to output 4k24 @4:2:2, which is 12-bit but not sure if I could do that or not, please advise, I read the forum but I am no expert not sure what to do


#62

Not yet. It would have to be configured via CLI for now

Sam


#63

What’s the command that I need to run to program it to 4k24 at 4:2:2?