444 10bit output from vero 4k


I’ve actually checked this and can confirm that sending a 10-bit 444 signal when playing back SDR content should not cause any ill effects.

The device will send a 10-bit signal, but the additional bits will be zeros for SDR content. This will be ignored by the receiving device if it follows the spec. If things look different, then it’s possible that your display is performing some dithering.

This has been confirmed by some other users, who state that there is no problem playing SDR content when Vero 4K is sending a 10-bit signal. I believe that others would have noticed colour problems if this was a widespread issue:

However, I can see merit in outputting an 8-bit signal when Rec709 content is being played. Even if just for the fact that you should be able to see how Vero 4K is interpreting the file and what the signal should be.



Hey Sam. You configured my box to send 10 bit for SDR as well. There is no problem if the box is sending 10 bit signal with SDR content. Nor there is a problem when the box sends a 10 bit signal with 4k HDR(Bt.2020) content. The problem arises when it sends a 10 bit signal with 4k BT.709 content . In this situation the box switches to Bt.2020 when the content is BT.709. Thats where the oversaturated colors and skintones appear. And again bit depth has nothing to do with colorspace. You can play something that is in SDR by upsampling it up to 12 bits but the colorspace should remain BT.709 because that is how its encoded. 4k files encoded in SDR have the problem am trying to illustrate.


This shouldn’t be happening.
Anyway – this is now being worked on and when I have some progress I will of course let you know. It definitely makes sense to add some GUI options to configure all of this.



This would be a great option as I believe the file should always be Output to the TV as it is encoded. Content is pretty limited at the moment, but will get more common as time goes on.
Thanks for looking into this Sam.


I’m a bit confused as a new owner… do I need to set the 444,10bit mode to the attr to get the proper HDR playback or should I leave the device configuration as is?

I can’t really say I see any difference when playing 4k HDR mkvs, and leaving the color space to auto on my TV seems to yield the same results as setting it to BT.2020 manually.

What I did notice was over-saturated colors when playing 8 bit 4k mkvs, if I set 444,10bit - same as the others. I could fix this by manually setting the color space on the TV, but using auto would throw it into BT.2020. Leaving the device as is seems to send the correct color space information and there’s no over-saturation.


You may need to, if Vero 4K is unable to correctly ascertain that your TV supports 10-bit HDR. There will soon be a menu option for this.



I see. Any way to check what Vero 4k determined is supported? :slight_smile:

cat /sys/class/amhdmitx/amhdmitx0/hdr_cap


Thanks for the help Sam. I’m looking at the output, but don’t see any mention of color spaces? Only states “Traditional HDR: 0”, which I would presume would have to be 1 and not a 0, yet the TV switches to HDR mode when playing the appropriate mkv.

I must admit I don’t completly understand how the output of hdr_cap could be linked to outputing 10bit or 8bit color when in HDR mode? :slight_smile:


Is the workaround which was mentioned in this thread already implemented in the new update? Or it will come with next one?


With the latest update, on my test setup with an LG TV, I no longer need to set the display manually in rc.local.

Colourspace switching and HDR to SDR is switching automatically with my TV



Regarding this, I’ve previously added

echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr

to my /etc/rc.local file - which successfully forced 10bit - does rc.local now need clearing?

Not about 10bit, but I’d also created an advancedsettings.xml with:

1 524880000 5.0

which cured buffering issues for me

these advancedsettings are still there after the december update, should/can the contents be removed?

All seems to be working as is but wondering if they should be tidied up?

Thanks for any help


It doesn’t need clearing, but doesn’t need setting either if that makes sense.

It would be good to know if you can remove them without any ill effect, i.e. if our settings are doing the trick.



Hi Sam

Deleted my advancedsettings.xml, rebooted and all seems well - no buffering (so far. only played 5-10 mins of a few files).

However, cleared the rc.local file and now my AV receiver (Marantz SR7011) doesn’t detect 10bit. It did report 10bit for everything, including 8bit files before this change.

This was the 140mbps 4k 10bit Jellyfish file.

And below, hopefully, as I’m not sure how the formatting works here, the 60mbps 10bit version.

Any suggestions?


Unfortunately this means we aren’t able to determine your TV / AVR supported 10-bit and switch accordingly.

Have you tried with an HDR sample to see if that correctly switches over?


Just tried an HDR sample. The TV (Sammy 55KS7000) switches to HDR, the amp reports 8bit and then this after reinstating the rc.local to as before:

Am I stuck to one or the other then, without changing manually each time?


For now, yes. We can probably add a Kodi GUI option in the future to automate flipping between this.
If your TV shows HDR, it should be 10-bit

Can you paste some logs so I can see your EDID?



OK, I’ll just have to read up on how to do that!


If you have SSH access easiest is grab-logs -A otherwise via MyOSMC/Log Uploader


Many thanks for that. Am starting to get used to Putty.

Hopefully this is what you were after. I had just rebooted and this is with my modified rc.local file.